changeset 51273:c12c79a49ca2

8205183: Warning about using VS2017 should be removed Reviewed-by: prr, tbell
author erikj
date Tue, 19 Jun 2018 16:44:41 +0200
parents f9f2e6a6a7b2
children a92d5b312116
files make/autoconf/toolchain_windows.m4
diffstat 1 files changed, 8 insertions(+), 1 deletions(-) [+]
line wrap: on
line diff
--- a/make/autoconf/toolchain_windows.m4	Tue Jun 19 16:29:48 2018 +0200
+++ b/make/autoconf/toolchain_windows.m4	Tue Jun 19 16:44:41 2018 +0200
@@ -37,6 +37,7 @@
 VS_SDK_INSTALLDIR_2010="Microsoft SDKs/Windows/v7.1"
 VS_VS_PLATFORM_NAME_2010="v100"
 VS_SDK_PLATFORM_NAME_2010="Windows7.1SDK"
+VS_SUPPORTED_2010=false
 
 VS_DESCRIPTION_2012="Microsoft Visual Studio 2012"
 VS_VERSION_INTERNAL_2012=110
@@ -47,6 +48,7 @@
 VS_SDK_INSTALLDIR_2012=
 VS_VS_PLATFORM_NAME_2012="v110"
 VS_SDK_PLATFORM_NAME_2012=
+VS_SUPPORTED_2012=false
 
 VS_DESCRIPTION_2013="Microsoft Visual Studio 2013"
 VS_VERSION_INTERNAL_2013=120
@@ -57,6 +59,7 @@
 VS_SDK_INSTALLDIR_2013=
 VS_VS_PLATFORM_NAME_2013="v120"
 VS_SDK_PLATFORM_NAME_2013=
+VS_SUPPORTED_2013=false
 
 VS_DESCRIPTION_2015="Microsoft Visual Studio 2015"
 VS_VERSION_INTERNAL_2015=140
@@ -70,6 +73,7 @@
 # The vcvars of 2015 breaks if 2017 is also installed. Work around this by
 # explicitly specifying Windows Kit 8.1 to be used.
 VS_ENV_ARGS_2015="8.1"
+VS_SUPPORTED_2015=false
 
 VS_DESCRIPTION_2017="Microsoft Visual Studio 2017"
 VS_VERSION_INTERNAL_2017=141
@@ -82,6 +86,7 @@
 VS_SDK_INSTALLDIR_2017=
 VS_VS_PLATFORM_NAME_2017="v141"
 VS_SDK_PLATFORM_NAME_2017=
+VS_SUPPORTED_2017=true
 
 ################################################################################
 
@@ -266,6 +271,7 @@
     eval MSVCR_NAME="\${VS_MSVCR_${VS_VERSION}}"
     eval MSVCP_NAME="\${VS_MSVCP_${VS_VERSION}}"
     eval USE_UCRT="\${VS_USE_UCRT_${VS_VERSION}}"
+    eval VS_SUPPORTED="\${VS_SUPPORTED_${VS_VERSION}}"
     eval PLATFORM_TOOLSET="\${VS_VS_PLATFORM_NAME_${VS_VERSION}}"
     VS_PATH="$TOOLCHAIN_PATH:$PATH"
 
@@ -312,6 +318,7 @@
       eval MSVCR_NAME="\${VS_MSVCR_${VS_VERSION}}"
       eval MSVCP_NAME="\${VS_MSVCP_${VS_VERSION}}"
       eval USE_UCRT="\${VS_USE_UCRT_${VS_VERSION}}"
+      eval VS_SUPPORTED="\${VS_SUPPORTED_${VS_VERSION}}"
       # The rest of the variables are already evaled while probing
       AC_MSG_NOTICE([Found $VS_DESCRIPTION])
       break
@@ -319,7 +326,7 @@
   done
 
   TOOLCHAIN_DESCRIPTION="$VS_DESCRIPTION"
-  if test "$TOOLCHAIN_VERSION" -gt 2013; then
+  if test "x$VS_SUPPORTED" = "xfalse"; then
     UNSUPPORTED_TOOLCHAIN_VERSION=yes
   fi
 ])