comparison make/common/shared/Defs-versions.gmk @ 3966:aa13e7702cd9

Merge
author ohair
date Tue, 29 Mar 2011 20:19:55 -0700
parents 0858c48466f0 54d8193f177b
children 241d5769859e 8e9e28663c5d
comparison
equal deleted inserted replaced
16:8f3c689e261d 17:c995a6c70af1
1 # 1 #
2 # Copyright (c) 2009, 2010, Oracle and/or its affiliates. All rights reserved. 2 # Copyright (c) 2009, 2011, Oracle and/or its affiliates. All rights reserved.
3 # DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER. 3 # DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
4 # 4 #
5 # This code is free software; you can redistribute it and/or modify it 5 # This code is free software; you can redistribute it and/or modify it
6 # under the terms of the GNU General Public License version 2 only, as 6 # under the terms of the GNU General Public License version 2 only, as
7 # published by the Free Software Foundation. Oracle designates this 7 # published by the Free Software Foundation. Oracle designates this
136 else 136 else
137 REQUIRED_FREE_SPACE = 1040000 137 REQUIRED_FREE_SPACE = 1040000
138 endif 138 endif
139 REQUIRED_COMPILER_NAME = Sun Studio 12 Update 1 139 REQUIRED_COMPILER_NAME = Sun Studio 12 Update 1
140 REQUIRED_COMPILER_VERSION = SS12u1 140 REQUIRED_COMPILER_VERSION = SS12u1
141 ifeq ($(CC_VERSION),sun) 141 # Cross-compilation compiler versions are target specific
142 REQUIRED_CC_VER = 5.10 142 # so don't set a required version if cross-compiling
143 endif 143 ifndef CROSS_COMPILE_ARCH
144 ifeq ($(CC_VERSION),gcc) 144 ifeq ($(CC_VERSION),sun)
145 REQUIRED_CC_VER = 3.4.3 145 REQUIRED_CC_VER = 5.10
146 endif
147 ifeq ($(CC_VERSION),gcc)
148 REQUIRED_CC_VER = 3.4.3
149 endif
146 endif 150 endif
147 REQUIRED_GCC_VER = 2.95.2 151 REQUIRED_GCC_VER = 2.95.2
148 endif 152 endif
149 153
150 # Linux specific 154 # Linux specific
156 REQUIRED_FREE_SPACE = 1460000 160 REQUIRED_FREE_SPACE = 1460000
157 REQUIRED_ALSA_VERSION = 0.9.1 161 REQUIRED_ALSA_VERSION = 0.9.1
158 REQUIRED_COMPILER_NAME = GCC4 162 REQUIRED_COMPILER_NAME = GCC4
159 REQUIRED_COMPILER_VERSION = GCC4 163 REQUIRED_COMPILER_VERSION = GCC4
160 REQUIRED_GCC_VER = 2.95 164 REQUIRED_GCC_VER = 2.95
161 ifeq ($(CC_VERSION),gcc) 165 # Cross-compilation compiler versions are target specific
162 REQUIRED_CC_VER = 4.3.0 166 # so don't set a required version if cross-compiling
163 endif 167 ifndef CROSS_COMPILE_ARCH
164 ifeq ($(CC_VERSION),sun) 168 ifeq ($(CC_VERSION),gcc)
165 REQUIRED_CC_VER = 5.10 169 REQUIRED_CC_VER = 4.3.0
170 endif
171 ifeq ($(CC_VERSION),sun)
172 REQUIRED_CC_VER = 5.10
173 endif
166 endif 174 endif
167 endif 175 endif
168 176
169 # Windows specific 177 # Windows specific
170 ifeq ($(PLATFORM), windows) 178 ifeq ($(PLATFORM), windows)