changeset 2329:34c2b2497b60

8151497: Set REQUIRED_OS_NAME and REQUIRED_OS_VERSION on AIX Reviewed-by: erikj
author simonis
date Wed, 09 Mar 2016 11:15:04 +0100
parents 672174fe5bf9
children 55fdc41df143
files common/autoconf/generated-configure.sh common/autoconf/platform.m4
diffstat 2 files changed, 9 insertions(+), 1 deletions(-) [+]
line wrap: on
line diff
--- a/common/autoconf/generated-configure.sh	Tue Mar 08 19:03:30 2016 -0800
+++ b/common/autoconf/generated-configure.sh	Wed Mar 09 11:15:04 2016 +0100
@@ -4862,7 +4862,7 @@
 #CUSTOM_AUTOCONF_INCLUDE
 
 # Do not change or remove the following line, it is needed for consistency checks:
-DATE_WHEN_GENERATED=1456136781
+DATE_WHEN_GENERATED=1457518447
 
 ###############################################################################
 #
@@ -15118,6 +15118,10 @@
     REQUIRED_OS_NAME=Darwin
     REQUIRED_OS_VERSION=11.2
   fi
+  if test "x$OPENJDK_TARGET_OS" = "xaix"; then
+    REQUIRED_OS_NAME=AIX
+    REQUIRED_OS_VERSION=7.1
+  fi
 
 
 
--- a/common/autoconf/platform.m4	Tue Mar 08 19:03:30 2016 -0800
+++ b/common/autoconf/platform.m4	Wed Mar 09 11:15:04 2016 +0100
@@ -406,6 +406,10 @@
     REQUIRED_OS_NAME=Darwin
     REQUIRED_OS_VERSION=11.2
   fi
+  if test "x$OPENJDK_TARGET_OS" = "xaix"; then
+    REQUIRED_OS_NAME=AIX
+    REQUIRED_OS_VERSION=7.1
+  fi
 
   AC_SUBST(REQUIRED_OS_NAME)
   AC_SUBST(REQUIRED_OS_VERSION)