changeset 988:6f48c590bae5

8029908: jdk 8u5 mac build produces incorrect version string 1.8.0_5 Reviewed-by: tbell, ihse
author erikj
date Mon, 16 Dec 2013 13:56:08 +0100
parents a225b62641b3
children c41935d79b87
files common/autoconf/generated-configure.sh common/autoconf/jdk-options.m4
diffstat 2 files changed, 13 insertions(+), 1 deletions(-) [+]
line wrap: on
line diff
--- a/common/autoconf/generated-configure.sh	Sun Dec 08 20:13:39 2013 -0800
+++ b/common/autoconf/generated-configure.sh	Mon Dec 16 13:56:08 2013 +0100
@@ -3865,7 +3865,7 @@
 #CUSTOM_AUTOCONF_INCLUDE
 
 # Do not change or remove the following line, it is needed for consistency checks:
-DATE_WHEN_GENERATED=1384422786
+DATE_WHEN_GENERATED=1387198493
 
 ###############################################################################
 #
@@ -11156,6 +11156,12 @@
     as_fn_error $? "Update version must have a value" "$LINENO" 5
   elif test "x$with_update_version" != x; then
     JDK_UPDATE_VERSION="$with_update_version"
+    # On macosx 10.7, it's not possible to set --with-update-version=0X due
+    # to a bug in expr (which reduces it to just X). To work around this, we
+    # always add a 0 to one digit update versions.
+    if test "${#JDK_UPDATE_VERSION}" = "1"; then
+      JDK_UPDATE_VERSION="0${JDK_UPDATE_VERSION}"
+    fi
   fi
 
 
--- a/common/autoconf/jdk-options.m4	Sun Dec 08 20:13:39 2013 -0800
+++ b/common/autoconf/jdk-options.m4	Mon Dec 16 13:56:08 2013 +0100
@@ -423,6 +423,12 @@
     AC_MSG_ERROR([Update version must have a value])
   elif test "x$with_update_version" != x; then
     JDK_UPDATE_VERSION="$with_update_version"
+    # On macosx 10.7, it's not possible to set --with-update-version=0X due
+    # to a bug in expr (which reduces it to just X). To work around this, we
+    # always add a 0 to one digit update versions.
+    if test "${#JDK_UPDATE_VERSION}" = "1"; then
+      JDK_UPDATE_VERSION="0${JDK_UPDATE_VERSION}"
+    fi
   fi
 
   AC_ARG_WITH(user-release-suffix, [AS_HELP_STRING([--with-user-release-suffix],