changeset 6913:01e6096da640

8054547: Re-enable warning for incompatible java launcher Summary: Re-enabled warning as launcher change reached promotion build Reviewed-by: hseigel, coleenp
author zgu
date Thu, 14 Aug 2014 13:15:23 -0400
parents a59f28b051ef
children 4a937a64c20b
files src/share/vm/runtime/arguments.cpp
diffstat 1 files changed, 3 insertions(+), 3 deletions(-) [+]
line wrap: on
line diff
--- a/src/share/vm/runtime/arguments.cpp	Tue Aug 12 21:16:05 2014 -0400
+++ b/src/share/vm/runtime/arguments.cpp	Thu Aug 14 13:15:23 2014 -0400
@@ -3596,9 +3596,9 @@
 #if INCLUDE_NMT
     if (match_option(option, "-XX:NativeMemoryTracking", &tail)) {
       // The launcher did not setup nmt environment variable properly.
-//      if (!MemTracker::check_launcher_nmt_support(tail)) {
-//        warning("Native Memory Tracking did not setup properly, using wrong launcher?");
-//      }
+      if (!MemTracker::check_launcher_nmt_support(tail)) {
+        warning("Native Memory Tracking did not setup properly, using wrong launcher?");
+      }
 
       // Verify if nmt option is valid.
       if (MemTracker::verify_nmt_option()) {