comparison README-builds.html @ 821:b9587f41fd55

8016780: README-builds.html misses crucial requirement on bootstrap JDK Reviewed-by: dholmes, chegar
author smarks
date Tue, 18 Jun 2013 17:18:46 -0700
parents d3e3d5b06f45
children f8405a0fa69c
comparison
equal deleted inserted replaced
35:53845c04255a 36:77f8a6161f6e
353 Be sure the GNU make utility is version 3.81 or newer, 353 Be sure the GNU make utility is version 3.81 or newer,
354 e.g. run "<code>make -version</code>" 354 e.g. run "<code>make -version</code>"
355 </li> 355 </li>
356 <li> 356 <li>
357 Install a 357 Install a
358 <a name="bootjdk">Bootstrap JDK</a> 358 <a name="bootjdk">Bootstrap JDK</a>.
359 <br>
360 All OpenJDK builds require access to a previously released 359 All OpenJDK builds require access to a previously released
361 JDK, this is often called a bootstrap JDK. 360 JDK called the <i>bootstrap JDK</i> or <i>boot JDK.</i>
362 Currently, for this JDK release we require 361 The general rule is that the bootstrap JDK
363 JDK 7 Update 7 or newer. 362 must be an instance of the previous major
363 release of the JDK. In addition, there may be
364 a requirement to use a release at or beyond a
365 particular update level.
366 <br>&nbsp;<br>
367
368 <b><i>Building JDK 8 requires use of a version
369 of JDK 7 that is at Update 7 or newer. JDK 8
370 developers should not use JDK 8 as the boot
371 JDK, to ensure that JDK 8 dependencies are
372 not introduced into the parts of the system
373 that are built with JDK 7.</i></b>
374
375 <br>&nbsp;<br>
364 The JDK 7 binaries can be downloaded from Oracle's 376 The JDK 7 binaries can be downloaded from Oracle's
365 <a href="http://www.oracle.com/technetwork/java/javase/downloads/index.html" 377 <a href="http://www.oracle.com/technetwork/java/javase/downloads/index.html"
366 target="_blank">JDK 7 download site</a>. 378 target="_blank">JDK 7 download site</a>.
367 For build performance reasons 379 For build performance reasons
368 is very important that this bootstrap JDK be made available 380 is very important that this bootstrap JDK be made available