changeset 6585:c1c6f4066627

RT-35478: Gradle complains about deprecated api Summary: Switch from configurations.add to configurations.create Reviewed-By: kcr
author Danno Ferrin (shemnon) <danno.ferrin@oracle.com>
date Tue, 01 Apr 2014 10:11:52 -0600
parents a1509d3a22bf
children 0e3825fffe37
files build.gradle buildSrc/build.gradle
diffstat 2 files changed, 2 insertions(+), 2 deletions(-) [+]
line wrap: on
line diff
--- a/build.gradle	Tue Apr 01 14:02:53 2014 +0300
+++ b/build.gradle	Tue Apr 01 10:11:52 2014 -0600
@@ -1221,7 +1221,7 @@
 project(":graphics") {
     // Workaround for lack of Antlr 3 support in Gradle. By defining a configuration,
     // we can then give it a class path and use that classpath to execute a java command
-    getConfigurations().add("antlr3");
+    getConfigurations().create("antlr3");
 
     sourceSets {
         main
--- a/buildSrc/build.gradle	Tue Apr 01 14:02:53 2014 +0300
+++ b/buildSrc/build.gradle	Tue Apr 01 10:11:52 2014 -0600
@@ -78,7 +78,7 @@
 
 // Workaround for lack of Antlr 3 support in Gradle. By defining a configuration,
 // we can then give it a class path and use that classpath to execute a java command
-getConfigurations().add("antlr3");
+getConfigurations().create("antlr3");
 
 dependencies {
     compile     group: "org.antlr", name: "antlr",          version: "3.1.3"