changeset 10843:03d6c4487f90

8194062: Remove support for libavcodec 53 and 55 Reviewed-by: kcr
author almatvee
date Fri, 16 Feb 2018 16:16:52 -0800
parents d4c0f65a3bbb
children 1438734a46e3
files build.gradle modules/javafx.media/src/main/native/gstreamer/gstreamer-lite/gstreamer/gst/gstregistry.c
diffstat 2 files changed, 6 insertions(+), 16 deletions(-) [+]
line wrap: on
line diff
--- a/build.gradle	Fri Feb 16 15:58:52 2018 -0800
+++ b/build.gradle	Fri Feb 16 16:16:52 2018 -0800
@@ -2963,9 +2963,7 @@
 
     dependencies {
         if (IS_BUILD_LIBAV_STUBS) {
-            media name: "libav-0.7.3", ext: "tar.gz"
             media name: "libav-9.14", ext: "tar.gz"
-            media name: "libav-10.7", ext: "tar.gz"
             media name: "libav-11.4", ext: "tar.gz"
             media name: "libav-12.1", ext: "tar.gz"
             media name: "ffmpeg-3.3.3", ext: "tar.gz"
@@ -3172,8 +3170,8 @@
                     doLast {
                         project.ext.libav = [:]
                         project.ext.libav.basedir = "${buildDir}/native/linux/libav"
-                        project.ext.libav.versions = [ "0.7.3", "9.14", "10.7", "11.4", "12.1" ]
-                        project.ext.libav.versionmap = [ "0.7.3" : "53", "9.14" : "54", "10.7" : "55", "11.4" : "56", "12.1" : "57" ]
+                        project.ext.libav.versions = [ "9.14", "11.4", "12.1" ]
+                        project.ext.libav.versionmap = [ "9.14" : "54", "11.4" : "56", "12.1" : "57" ]
 
                         libav.versions.each { version ->
                             def libavDir = "${libav.basedir}/libav-${version}"
@@ -3202,18 +3200,10 @@
                                     }
                                     exec {
                                         workingDir("$libavDir")
-                                        if (version.equals("0.7.3")) {
-                                            if (IS_BUILD_WORKING_LIBAV) {
-                                                commandLine("sh", "configure", "--enable-shared", "--disable-debug", "--disable-static", "--disable-yasm", "--disable-doc", "--disable-everything", "--disable-mmx", "--disable-mmx2", "--enable-decoder=aac,mp3,mp3float,h264", "--enable-parser=aac,h264", "--enable-demuxer=aac,h264,mpegts,mpegtsraw")
-                                            } else {
-                                                commandLine("sh", "configure", "--enable-shared", "--disable-debug", "--disable-static", "--disable-yasm", "--disable-doc", "--disable-everything", "--disable-mmx", "--disable-mmx2")
-                                            }
+                                        if (IS_BUILD_WORKING_LIBAV) {
+                                            commandLine(cfgCMDArgs + commonCfgArgs + codecsCfgArgs)
                                         } else {
-                                            if (IS_BUILD_WORKING_LIBAV) {
-                                                commandLine(cfgCMDArgs + commonCfgArgs + codecsCfgArgs)
-                                            } else {
-                                                commandLine(cfgCMDArgs + commonCfgArgs)
-                                            }
+                                            commandLine(cfgCMDArgs + commonCfgArgs)
                                         }
                                     }
                                 }
--- a/modules/javafx.media/src/main/native/gstreamer/gstreamer-lite/gstreamer/gst/gstregistry.c	Fri Feb 16 15:58:52 2018 -0800
+++ b/modules/javafx.media/src/main/native/gstreamer/gstreamer-lite/gstreamer/gst/gstregistry.c	Fri Feb 16 16:16:52 2018 -0800
@@ -158,7 +158,7 @@
 #include <dlfcn.h>
 
 // For libav (libavcodec.so)
-static const int AVCODEC_LIBAV_EXPLICIT_VERSIONS[] = { 53, 54, 55, 56 };
+static const int AVCODEC_LIBAV_EXPLICIT_VERSIONS[] = { 54, 56 };
 // For ffmpeg (libavcodec-ffmpeg.so)
 static const int AVCODEC_FFMPEG_EXPLICIT_VERSIONS[] = { 56 };
 // For libav or ffmpeg (libavcodec.so)