changeset 2755:49a15c503104

8184338: switch minimum supported gcc version to 4.7 Reviewed-by: erikj, tbell
author mbaesken
date Tue, 18 Jul 2017 14:42:03 -0700
parents 0aaea19fca61
children 2fe66ca1e2b3
files common/autoconf/generated-configure.sh common/autoconf/toolchain.m4 common/doc/building.md
diffstat 3 files changed, 5 insertions(+), 8 deletions(-) [+]
line wrap: on
line diff
--- a/common/autoconf/generated-configure.sh	Mon Jul 17 23:11:46 2017 -0700
+++ b/common/autoconf/generated-configure.sh	Tue Jul 18 14:42:03 2017 -0700
@@ -5014,7 +5014,7 @@
 
 # Minimum supported versions, empty means unspecified
 TOOLCHAIN_MINIMUM_VERSION_clang="3.2"
-TOOLCHAIN_MINIMUM_VERSION_gcc="4.3"
+TOOLCHAIN_MINIMUM_VERSION_gcc="4.7"
 TOOLCHAIN_MINIMUM_VERSION_microsoft="16.00.30319.01" # VS2010
 TOOLCHAIN_MINIMUM_VERSION_solstudio="5.13"
 TOOLCHAIN_MINIMUM_VERSION_xlc=""
@@ -5193,7 +5193,7 @@
 #CUSTOM_AUTOCONF_INCLUDE
 
 # Do not change or remove the following line, it is needed for consistency checks:
-DATE_WHEN_GENERATED=1500048914
+DATE_WHEN_GENERATED=1500410254
 
 ###############################################################################
 #
--- a/common/autoconf/toolchain.m4	Mon Jul 17 23:11:46 2017 -0700
+++ b/common/autoconf/toolchain.m4	Tue Jul 18 14:42:03 2017 -0700
@@ -52,7 +52,7 @@
 
 # Minimum supported versions, empty means unspecified
 TOOLCHAIN_MINIMUM_VERSION_clang="3.2"
-TOOLCHAIN_MINIMUM_VERSION_gcc="4.3"
+TOOLCHAIN_MINIMUM_VERSION_gcc="4.7"
 TOOLCHAIN_MINIMUM_VERSION_microsoft="16.00.30319.01" # VS2010
 TOOLCHAIN_MINIMUM_VERSION_solstudio="5.13"
 TOOLCHAIN_MINIMUM_VERSION_xlc=""
--- a/common/doc/building.md	Mon Jul 17 23:11:46 2017 -0700
+++ b/common/doc/building.md	Tue Jul 18 14:42:03 2017 -0700
@@ -392,11 +392,8 @@
 
 ### gcc
 
-The minimum accepted version of gcc is 4.3. Older versions will not be accepted
-by `configure`.
-
-However, gcc 4.3 is quite old and OpenJDK is not regularly tested on this
-version, so it is recommended to use a more modern gcc.
+The minimum accepted version of gcc is 4.7. Older versions will generate a warning 
+by `configure` and are unlikely to work.
 
 OpenJDK 9 includes patches that should allow gcc 6 to compile, but this should
 be considered experimental.