comparison make/linux/Makefile @ 9241:4a2b42389965

Added tag jdk8u242-b02-aarch32-191202 for changeset 77f97ed92558
author snazarki
date Mon, 02 Dec 2019 13:33:54 +0300
parents bd33e3fce750
children
comparison
equal deleted inserted replaced
24:1d08c17de7b6 25:97f9ccc34c46
225 @echo " $(TARGETS_CORE)" 225 @echo " $(TARGETS_CORE)"
226 @echo " $(TARGETS_ZERO)" 226 @echo " $(TARGETS_ZERO)"
227 @echo " $(TARGETS_SHARK)" 227 @echo " $(TARGETS_SHARK)"
228 @echo " $(TARGETS_MINIMAL1)" 228 @echo " $(TARGETS_MINIMAL1)"
229 229
230 checks: check_os_version check_j2se_version 230 checks: check_j2se_version
231
232 # We do not want people accidentally building on old systems (e.g. Linux 2.2.x,
233 # Solaris 2.5.1, 2.6).
234 # Disable this check by setting DISABLE_HOTSPOT_OS_VERSION_CHECK=ok.
235
236 SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3% 4%
237 OS_VERSION := $(shell uname -r)
238 EMPTY_IF_NOT_SUPPORTED = $(filter $(SUPPORTED_OS_VERSION),$(OS_VERSION))
239
240 check_os_version:
241 ifeq ($(DISABLE_HOTSPOT_OS_VERSION_CHECK)$(EMPTY_IF_NOT_SUPPORTED),)
242 $(QUIETLY) >&2 echo "*** This OS is not supported:" `uname -a`; exit 1;
243 endif
244 231
245 # jvmti.make requires XSLT (J2SE 1.4.x or newer): 232 # jvmti.make requires XSLT (J2SE 1.4.x or newer):
246 XSLT_CHECK = $(REMOTE) $(RUN.JAVAP) javax.xml.transform.TransformerFactory 233 XSLT_CHECK = $(REMOTE) $(RUN.JAVAP) javax.xml.transform.TransformerFactory
247 # If not found then fail fast. 234 # If not found then fail fast.
248 check_j2se_version: 235 check_j2se_version: